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Tactile Graphics Translation Process Overview 

The Tactile Graphics Project is aimed at streamlining the tactile image translation process to produce graphics in the most efficient way. This means, with the right tools, producing images that are inexpensive, quick, and easily customizable. The workflow we have designed below achieves this goal:
Programs and resources to get started
This step lays out what you will need to complete the tactile graphic translation process and provides a few helpful tips.
Step 1: Obtain images in proper format and rename
In this step, you will scan the images and put them into the correct file format using Photoshop. 
Step 2: Preprocess with Photoshop
Using your images, you will crop and threshold them to prepare them for the TGA.
Step 3: Classify images and create working folders
In this step, you will divide the images into different subfolders based on similar characteristics. This helps to reduce errors when batch processing in the TGA.
Step 4: The TGA
The TGA will extract and separate the text from your images. The TGA’s output are a text-free image and an image that contains only the text labels.
Step 5: OCR
Using the image containing only the text labels, you will use OCR to turn the image into text labels.
Step 6: Braille Translation
The text labels will be translated into Grade 2 Literary Braille.
Step 7: Using the Scripts
The first script will resize your text-less images and the second script will place Braille text onto those images.
Step 8: Editing in Illustrator and Photoshop
In this step, you will touch up your images and finalize them.
Workflow Chart
This chart will give you a visual image of the translation process described above.

Programs and resources to get started
1. Before you begin, you will need:

a) A Braille 29 font and an OCR A Extended font, both of which are included with the download package.
Instructions for installing a font can be found at:

http://support.microsoft.com/kb/314960
b) About three gigabytes of hard disk space during the process and one gigabyte of memory.
c) About 50 megabytes of hard disk space for the final images.

2. For image editing and Braille placement, you will need Adobe Photoshop and Illustrator. We currently use CS4 but older versions work as well.
3. For Optical Character Recognition, you will need Scansoft OmniPage, ABBYY Finereader, or Infty Reader / Editor. We use OmniPage for images that don’t contain equations and Infty Reader for images that do.
4. For Grade 2 Braille translation, we use Duxbury. Braille2000 is another popular translation program that works.
5. For the ‘Number of Lines’ script, you will need Perl installed.
6. TIP: Links to all the software websites are listed in the appendix.

7. If this is your first time going through the process, complete the process on the 3 images in the “Practice Images” folder included with the download package so you can compare your results to ours. They are easier than most images and will help introduce you to everything. When you get through those, try the “Batch Practice Images” to practice doing batch processes.
8. The images in this tutorial have been shrunk. You probably won’t be able to see them so expand them. Also, the text boxes with red font inside the pictures can be moved aside if they are blocking your view.
9. If you need any help with the process, do not be afraid to contact us at any time and ask us questions! You can email us or visit our support forum at http://uwtga.freeforums.org/index.php where you can post suggestions and questions.
Step 1:  Obtain images in proper format and rename
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1. If you have books in PDF, EPS, or TIFF format, take a look at the appendix for extracting images from them.

2. Scan the hard copy images from the book:

a) Scan to a .BMP, .JPEG, .TIF file format with at least 150 dpi. 
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Scan in color mode, even if the images are grayscale.
3. To separate the images from the page (you will need to do this for all images):
a) Open the scanned file in Photoshop and use the Marquee or lasso tool in the bar on the left to select a part of the image. Edit → Copy the selection and then do: File → New. Shortcut: To copy a selected part, push ‘CTRL C’. To create a new file, push ‘CTRL N’.
b) The image name should have a consistent format, such as “fig”chapter-number.  For example: fig8-15, fig27-1, fig13-4a.

c) The Preset should say Clipboard.
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The Color Mode should be in RGB Color. 8-bit is good.

e) Click OK and Edit → Paste the image you copied. Now File → Save As → Choose format: .BMP → OK → Choose depth: 24-bit → OK.
Shortcut: To paste a selected part, push ‘CTRL V’.
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Repeat this for all the images you find in the text.
TIP: If your image has multiple pieces, separate it into a single Photoshop file for each.
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Step 2: Preprocess with Photoshop 
1. Crop the images: 
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To crop the images in Photoshop, choose the crop tool. Select the whole image and then drag the corners to expand your image. Apply the changes by clicking the checkmark. TIP: To select the whole image, you can either push ‘CTRL A’ or you can zoom out to make the selection easier by pushing ‘CTRL -’.
b) Check the appendix if you want the specifications of Braille character sizes.
c) You will usually need to add at least 1 additional line (0.5 inches) of Braille above the image for the figure name and at least 2 additional lines (1 inch) below the image for copyright information.

d) TIP: To see how many inches to add, use: View → Rulers. If your ruler is not in inches, right click your ruler and select inches.

Shortcut: To view a ruler, push ‘CTRL R’.

e) Try to leave extra room on the left and right sides of the image for labels (especially the left side if there is a labeled y-axis). Braille29 font measures about 1/4 inch per character horizontally.

f) Touch up images by erasing stray dots and lines. To do this, select the eraser tool and choose your eraser diameter.
2. Apply thresholding to get clean images with a solid color text. 

It is a good idea to copy all of your cropped images before you apply thresholding just in case the batch processing doesn’t produce the results you want. The TGA works best with this kind of text. All scanned images will require thresholding since the scanning process introduces quite a bit of optical noise.
a) To threshold one image:

TIP: For the best thresholding viewing results, View → Fit on Screen. Shortcut: To fit an image to the screen, push ‘CTRL 0’.

i. Image → Adjustments → Threshold
ii. Make sure “Preview” box is checked.
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Move slider until you get solid text and clean lines. You want the text to look as thick and sharp as possible, but not so thick that the characters touch each other (However, it is OK if a few character touch each other).
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Click OK and save. Shortcut: To save, push ‘CTRL S’.
v. TIP: You can create a shortcut for thresholding by Edit → Keyboard Shortcuts. Expand “Image” and find “Threshold”. Type in a shortcut and push “Accept”.
b) To apply thresholding to all images in a folder as a batch:

i. You will need to first categorize images according to line weights (thickness) and separate them into subfolders before batch processing. (If you do put the images in a subfolder, remember to take them out again when you are finished [image: image20.jpg]£ Adobe Photoshop - [fig0025a.bmp.
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thresholding so that all the images are in a single folder again before going on to Step 3.) Check the appendix for an [image: image21.jpg]-mmmwmmm»[\inv
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example of categorizing.
ii. Open one of your images in Photoshop.

iii. Window → Actions → (In the window that slides out) Create New Action (It is a button along the bottom bar of the slide out window).
iv. Name your new action (i.e. Threshold) and click record.

v. Repeat the process used to threshold one image (part (e)).
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Close the image and then click the stop button (blue square) on the Actions palette.
vii. [image: image23.jpg]


File → Automate → Batch
viii. Select your Action from the Action drop-down menu.
ix. For “Source” choose “Folder” from the drop-down menu and click the “Choose” button. Select the appropriate folder.
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The “Destination” is “Save and Close”
[image: image25.jpg]ToxtExiract - O:\unbprojocts\tactle2LJosh\Tutorial nages\imags
Fio Mede Tron Excate Ve 1eb
& Charsortiode € Labllede [~ tideSoted Chrsets
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If the image is very large consider splitting into multiple parts:
a) It is best if you can fit your final images onto standard 11.5 x 11 Braille paper. This means a final document size of no more than 11 x 11. (You need to leave the extra half inch of horizontal space for binding the pages together.)
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Keep in mind that the Braille text will most likely be much larger than the original text.

c) If there’s a key with lots of text, it might be best to make it a separate image.

d) To separate a large image into smaller parts in Photoshop:

i. Open the image and select the part of the image you want.
ii. Edit → Cut the selected part and then File → New. Shortcut: To cut, select the area you want and push ‘CTRL X’.
iii. The name should be the same as your original image except with another character added. (i.e. if the original image name was “fig1-23”, the new name could be “fig1-23b”).
iv. The “Preset” should say “Clipboard”. Click OK.
v. Edit → Paste your image and save. Don’t forget to crop it as well.
4. If there’s a key with very small textured areas, you may need to enlarge it to make the textures readable.

5. TIP: If you want to enlarge or move a piece of you image:

a) Open your image and then select the area you want to enlarge.
b) Edit → Transform → Scale. From here you can move, expand, shrink, or rotate that piece of your image.

Shortcut: Once you have selected an area, push ‘CTRL T’ to transform that piece of your image.

Step 3:  Classify images and create working folders

1. Classify images with similar features. 

a) Possible groupings include: Angled Text, Horizontal Text, No Text, Oversized, Complex, Grid Overlap, Text Overlap, Preserve Aspect Ratio, etc.

b) Make a separate folder for each grouping.

c) Good classification will improve automatic text recognition in the TGA.
2. Within each grouping folder, create a “Training” folder, an “Input” folder, an “Intermediate” folder, and an “Output” folder
3. Within the “Training” folder, create an “Input” folder, an “Intermediate” folder, and an “Output” folder.

4. Within each grouping folder, move all the images to the “Input” folder

5. Select several representative images of the class and move them to the “Training/Input” folder.

Step 4:  The TGA 

(See the document titled, “TGA Guide” for more detailed instructions and some important tips exclusive to the TGA.
The TGA Guide can be found at: tactilegraphics.cs.washington.edu/tga_guide.doc)
1. Setting up the TGA:
a) Open the TGA.

b) Choose “General Options” from the File menu.

Set height, width, output resolution, and levels of undo. (More levels will use more memory.) Check “preserve aspect ratio” if desired. (The defaults for the TGA options are: height=10, width=10, DPI=100, [image: image30.jpg]] [ otimmre | [@ memnc
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TIP: Preserving the aspect ratio will enlarge the image as much as it can without stretching it. If you choose not to preserve aspect ratio, either the vertical or horizontal axis will be stretched.
c) Set Input to be your “Training/Input” folder for this grouping.

d) Set Intermediate to your “Training/Intermediate” and set Output to be your “Training/Output” folders for this grouping.

2. Training the TGA:
a) Load an image File → Load. Shortcut: To load, push ‘CTRL L’.
b) Look at the Train → Options and use the color picker to define the color of text in your images. For black (the standard color from thresholding in Photoshop) you should have “0 0 0”.
c) Mark all characters in the image:
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Don’t forget to select the dot for the “i” character.
ii. A dash “-“ and equals “=” count as characters.
iii. If your threshold was applied too thickly, some characters may be joined together. This is fine; both will be selected as one character.
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If your threshold was applied too thinly, some characters may be broken up into a bunch of pieces. Just select all the pieces.
d) Mark all labels in the image.

TIP: If a label is more than one line, break up the label so that you get one label per line.
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e) Check the “Hide Selected” box to make it easier to see if you missed anything:

i. Look for unselected characters or parts of characters inside labels. 

ii. Also look for tiny labels inside of larger labels and remove them.
iii. Lower-case i’s and equals signs are common culprits for both.
f) Save the file. 

i. If you load the next image without saving, you will lose all your character and label markings. Save often!
ii. You will need those markings to update the training data if you close and re-open TGA.
g) Update the training data: Train → Update All: Characters & Labels. Shortcut: To update all, push ‘CTRL U’.
h) Repeat this step for all the other images in the training set.

i) TIP: When you close TGA the training data is not saved, but the marked characters and labels in each image are saved (as long as you remembered to save the file before loading another image). Therefore, if you have done training in a previous TGA session, you must go through each of your saved training images and choose “Train → Update All: Characters and Labels” to get the training data back from those images.
3. Batch processing for the TGA after you have the training data updated:
a) Choose “General Options” from the File menu.

b) Set Input to be the “Input” folder that is in the directory above your “Training/Input” folders.
c) Set Intermediate and Output to the folder in the parent directory of your “Training” folder like you did for part (b).

d) Select File → Batch Process and wait for the process to complete.

4. Editing in the TGA:
a) Check for errors in each image of the grouping. (Again, use “Hide Selected” to see what the TGA missed.)

b) After errors are corrected in each image, save the image.

Shortcut: To move to the next image, push ‘PGDN’ and to move the previous image, push ‘PGUP’.

c) If a mistake is consistent, update the training data:

i. Move a representative image from the grouping’s “Input” folder to the “Training/Input” folder. 

ii. Move the corresponding files from the grouping’s “Intermediate” and “Output” folders to “Training/Intermediate” and “Training/Output” respectively.

iii. Load the image and choose: Train → Update All Characters and Labels.
5. Repeat Steps 1 – 5 for all of the other image groupings in this project.
6. TIP: It’s important that you do not change the names of any files that are generated by TGA (the files in the Output folder) at any time during the image translation process. This is necessary for the files to be properly recognized by the various scripts.
7. TIP: The Intermediate folder is where TGA stores the information about which parts of the image are text. If you delete these files, you will not be able to generate the correct output files without starting over again.  

Step 5:  OCR – Repeat these steps for each set
Instructions are provided below for OmniPage Pro. However, other OCR software can be used. Most popular OCR software tools have similar batch processing capabilities. Check the appendix for instructions for InftyReader and InftyEditor.
Preliminary steps (do before using any of the options below):

1. Create a new “Text” folder where you will store the files for all of your images:
a) For all of your groupings, copy the text image files (files with the extension “SelLabelsNoBoxes.bmp”) from “Output” into your “Text” folder.
b) For all your groupings, copy matching xml files (files with same name but with extension “SelMBs” from “Output” to your “Text” folder.
c) Copy “numlines.pl” and “runnumlines.bat” from “Program Files/Tactile Graphics Assistant/Scripts” to “Text.”
d) Do not rename any of the files.  

Instructions for OmniPage Pro OCR (doesn’t recognize math notation)

If you do have a small amount of math notation (i.e. a few fractions, subscripts, superscripts, Greek characters, etc) and you still want to use OmniPage, be sure to look at the Nemeth Code section the appendix.
1. Batch processing for OmniPage:
a) Open OmniPage Batch Manager. (You can do this either through “Start/Program Files” or in the OmniPage application, go to Process → Batch Manager.)
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b) File → New Job.
c) Set “Load Image Files” as the first step.  

d) Load all the images from “Text”.
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e) Set “Recognize Images” as the second step.

f) Select English as the language to be recognized. Add + and – to the “Additional Characters” text box.
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g) Click the Font Matching box and remove all the fonts besides “OCR A Extended”.
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h) Set “Save as OPD” as the third step. Set the save folder to be “Text”. Provide a name for the OPD file (i.e. something to do with the title of your book). (All the files will be saved to one document – this is OK.)

i) Set “Finish Job” as the final step. 
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j) Give the job a name (preferably the same as your OPD filename) and click Finish. If you have a lot images, this may take some time.
2. Editing in OmniPage:
a) Open the saved OPD document.
TIP: If the computer runs really slowly when you open your large OPD, try splitting it into multiple OPDs.
b) Go to View. Set the “Page Image,” “Text Editor,” and “Thumbnail Image” to be visible.
c) TIP: If you see that all the labels are being jumbled together instead of each getting their own line in the Text Editor, go to Tools → Options → Text Editor tab and make sure Word Wrap is turned off. Also, to get better looking results, try changing the “Styles” in the upper left corner of the text editor. 
d) Make sure all text is the same font (OCR A Extended).
TIP: Making the text the same font makes it easier to find mistakes. If characters are different font sizes or are bolded / italicized, you don’t need to change their fonts or un-bold them to make them match; it should be OK to leave them as they are.
e) Go through each image and compare the image to the OCR result. Edit OCR result as necessary.

TIP: Sometimes OmniPage thinks the text is an image. To fix this, in the Image Panel, select “Draw text zone” and draw one around the whole image. Then redo the OCR by Process → Perform OCR → Start.
f) Go to File → Export Result → Save to File.
g) Navigate to “Text” folder.

h) Set “Files of type” to “Text with line breaks (*.txt)”. 

i) Set “File options” to “Create a new file for each image file”. 
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j) Click OK.

3. Performing the line count check:
a) Execute “runnumlines.bat” (double-click it in the “Text” folder).
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b) An output window will list files with incorrect number of lines.

TIP: The text file that OmniPage saved should not have a blank line in the beginning of the file, but it should have a blank line at the end of the file.
4. Backup the edited text files in “Text” to a separate folder. Do not rename files.

5. Optional: If you are using LaTex:
a) Math needs to be done with LaTex. Surround LaTex code with ‘$’.

b) If text files have Latex tags, text files need to be prepared for proper processing

c) Copy “appendlatex.pl” and “runappendlatex.bat” from “Program Files/Tactile Graphics Assistant/Scripts” to “Text”

d) Double click “runappendlatex.bat” to run it.
General info that applies to any OCR method:

1. If you didn’t use “Hide Selected Characters” in the TGA to very carefully check your image files, your text image files may get output with missing characters, resulting in mistakes such as: 

· n=2 output as n-2
· 10^-4 output as 10^4
· 10.5 output as 105
2. Therefore, always check your OCR text files against the original images.
3. If you discover an error like this when you check your OCR text file, fix up the text file to match the original image text. However, you will have to edit the corresponding image in Step 9. For example, in the case where you have 10.5 output as 105, you will have to fix up the text to be 10.5 and also edit the image in Step 9 to remove the stray “.” from the image since it wasn’t counted as text.
Step 6: Braille Translation – Repeat these steps for each set

(We use Duxbury Braille Translator for this step. Other Braille translation software can be used, but care must be taken to ensure that the resulting Braille document has the same number of lines as the original.)

1. Translating into Braille (a script to automate this will be available soon):
a) Open Duxbury

b) In Duxbury, open a text file or latex file from the “Text” folder. The Template should be “English (American) – Standard Literary Format”.
c) At the same time, open the same text file in a text editing program, like Notepad.
d) File → Translate to translate into Grade 2 Braille. 
Shortcut: To translate, push ‘Ctrl T’. 
e) Select all the translated text in Duxbury and copy it.
f) Switch back to the text editing program (i.e. Notepad) and paste in the translated text, replacing all the previous text.
TIP: Occasionally, pasting the text will create a blank first line so delete it. However, the text should have a blank line at the end of the file. 
TIP:  The text will look weird, but it is correct. For example “FIGURE 1.43” will appear as “,,figure #a.dc” after it is translated and pasted into the text file. 
g) Save the text file in the text editing program (i.e. Notepad). 
h) If you are using latex files, when saving, it’s easiest to show all files (by choosing “All Files” from the “Save as Type” dropdown box) and click the corresponding latex file and then add “.txt” to the end. This will save you from typing the entire “figname.SelLabelsNoBoxes.txt” for every file (where “figname” is the actual figure name.)

i) Repeat steps b) – i) for the rest of the text files in the folder.
2. Nemeth Code (for Greek characters, fractions, operations, etc) if needed. Check the appendix for Nemeth code insertion instructions.
3. Checking the line count:
a) Execute “runnumlines.bat” (double-click it in the “text” folder.)
b) An output window will notify you of all the files with incorrect number of lines.
Step 7: Applying the Scripts – Repeat steps for each set 

1. Resizing the images:
a) Open Photoshop.

b) Go to File → Scripts → Browse.
c) Browse to C:/Program Files/Tactile Graphics Assistant/Scripts/Photoshop/Scale Batch (select “JavaScript File” in the “Files of type” dropdown box if necessary, to make this script visible). Select “Scale Batch” and click “Load”.

TIP: This script resizes the images based on the settings you chose for the TGA in Step 4 part 1 and needs to be done for all images.
d) Set the work folder to be “Output” and click OK.

e) Let the batch run (this may take several minutes).
2. Label Placement:
a) Setting up the files:
i. Create a new folder called “Ready”.
ii. Move the images with the extension “.Resized” from the “Output” folder to the “Ready” folder.
iii. Copy the matching xml files from the “Output” folder to the “Ready” folder.
iv. Copy the matching text files from the “Text” folder to the “Ready” folder.
b) Batch processing in Illustrator:
i. Open Illustrator.
ii. Go to File → Script → Other Script
iii. Browse to C:/Program Files/Tactile Graphics Assistant/Scripts/Illustrator.
iv. Select “BrailleInsert Batch” and click “Open”.
v. A window will pop up asking for a source folder.  Set this to be “Ready”.
vi. Another window will pop up asking for a destination folder.  Set this to be “Ready”.
vii. Let the batch run (this may take several minutes).

Step 8: Editing in Illustrator and Photoshop – Repeat for each set

The best way to complete this step is to edit the Illustrator and corresponding Photoshop files at the same time before moving on to the next image. 
1. Editing images in Illustrator:

a) Open Illustrator.
b) Load an Illustrator file from “Ready”.
c) Create new textboxes and add the necessary info:

i. Top left: Figure number.
ii. Bottom left: Copyright information. 

TIP: The amount of copyright information to provide is up to you. We usually have the author, book title, and publisher.
iii. TIP: Use Duxbury to translate the above information into Braille and before inserting it.
d) Move the textboxes around to fit them within the edges of the page. 

i. TIP: You can break long text into separate lines when appropriate.
ii. TIP: If you need more room, you can enlarge the page workspace. Up to 11” x 11” will fit on normal Braille paper. Try not to go larger than that. If you must go larger, try to keep it under 16”x 30.” Do not go over 16”x 50”.
TIP: To edit the workspace dimensions, select the Artboard Tool. Shortcut: Press ‘Shift O’ to edit the dimensions.
e) If you want to resize the .bmp within your .ai file, click the “Layers” icon on the right toolbar. Find your .bmp file and double click it. Uncheck the “Lock” box. Now you should be able to resize your .bmp.

2. Editing in Photoshop (if your image needs to be cleaned up or reorganized):
a) Open Photoshop.
b) Load the corresponding “Resized.bmp” image from “Ready”.
c) Remove any unnecessary colors or stray marks. To touch up the image, select the eraser tool and choose your eraser diameter.
d) You may need to simplify the image if it is too cluttered or the text isn’t fitting. To format the layout of an image, recall the TIP: Edit → Transform → Scale. From here you can move, expand, shrink, or rotate that piece of your image.
e) Replace meaningful colors with textures/patterns. 
TIP: We have included 11 textures. To add them in Photoshop: Edit → Preset Manager → Preset Type: Patterns → Load. Find the file “Tactile Texture Patterns.pat” and open it. The ones without the “Threshold” in the name can be Thresholded to create textures as thick/thin as you need. If you want to make your own textures, check out the appendix. Repeat for the other Illustrator files and Photoshop images.
3. If you want to change the .bmp associated with a particular .ai file, go to Windows → Links and select the relink button.
4. Make a final check of your images by comparing the original images in the book to your own. Fix as necessary.

5. Embedding in Illustrator (bundles Photoshop and Illustrator files together so that they are a single Illustrator file):
a) Create a new folder called “Completed”.

b) Open Illustrator.
c) Go to File → Scripts → Other Script
d) Browse to C:/Program Files/Tactile Graphics Assistant/Scripts/Illustrator.

e) Select “Embed Links” and click “Open”.
f) Set the work folder to be “Ready” and the destination folder to be “Completed”.
g) Click OK. Let the batch run (this may take several minutes).

You are now done! Give yourself a pat on the back. Now all that’s left to do is to emboss the Adobe Illustrator (.ai) files if you want to. We use the Tiger Embosser to do this. If you don’t have access to an embosser, you can send the .ai files to some who does.

Using the TGA as Part of the Image Translation Process – Workflow Chart

The TGA is designed for use as one of the components of the tactile graphics translation workflow.  In this workflow, different software tools automate steps in the tactile graphics translation process.
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Appendix
Step 1:  Programs and resources to get started
1. Here are some example guidelines to keep in mind as you make your graphics:  http://www.tactilegraphics.org/designingtgs.html
2. Adobe Photoshop and Illustrator: http://www.adobe.com/products/
3. OmniPage: http://www.nuance.com/omnipage/
4. Duxbury: http://www.duxburysystems.com/dbt.asp?product=DBT%20Win
5. Strawberry Perl: http://strawberryperl.com/
Step 2:  Obtain images in proper format and rename
1. For other image sources, such as PDF, EPS, or TIFF, you will need to convert to 24-bit RGB bmp. First, copy the image and then paste it into Photoshop: 

a) TGA will not work with any other format besides RGB Color bmp. TIP: To check what format you have go to: Image → Mode. RGB Color is different from Bitmap. We use RGB Color format.

b) Black & white or grayscale images can be converted to RGB in Photoshop by: Image → Mode → RGB Color. (Black & whites must first be converted to grayscale then converted to RGB.) 

c) To extract images from a TIFF file, you can use Adobe Acrobat and convert the TIFF to a PDF.

d) To extract images from a PDF, use the image capture tool to copy the image to the clipboard and paste them into Photoshop. 

e) Photoshop can convert images to 24-bit bmp: 

File → Save As → Choose format: .BMP → Choose depth: 24-bit

TIP: If you cannot do this operation, try copying the image into Microsoft Paint and then saving it as a .BMP. Reopen the image in Photoshop and make sure you have the right format.

Step 3: Preprocess with Photoshop 
1. Specifications: We use Braille29 font which measures vertically about 5/16 inch per line. For Braille29 font, allow at least ½ inch per line of Braille, plus an extra ¼ inch of space between the Braille text and the edge of the page. (The official spec for American Standard Braille is 10.16 mm, equivalent to 0.4 inches, from the top of one line to the top of the next line.)

2. You will need to first categorize images according to line weights (thickness) and separate them into subfolders before batch processing. So, if some images have really thick lines, put them into a “Thick Lines” subfolder. If the text is really thin, you will want to make a folder “Text Thin” and add images with thin text in there. Now, because the images within each folder have similar threshold tolerances, batch thresholding on a folder should produce better results than thresholding on the entire image set. Make as many subfolders as necessary.
Step 6:  OCR
Instructions for InftyEditor (recognizes math notation and works better on TGA output)

InftyEditor doesn’t allow batch processing like InftyReader but it has the advantage of recognizing images that InftyReader rejects, including the text image outputs by the TGA (after they are upsampled by the procedure given below). However, please note that the OCR function of InftyEditor will not work unless InftyReader is installed as well.

1. Make sure you have done the “Preliminary Steps” listed at the beginning of Step 6.

2. Use Photoshop to get the .bmp files in “Text” ready for Infty (use actions scripts for batch processing):

a) Change the resolution to 400 DPI: 

i. Image → Image Size

ii. Set Resolution to 400 pixels per inch

iii. Make sure Scale Styles, Constrain Proportions, and Resample Image are all checked.

iv. Set Resample Image to Bicubic.

b) Reduce image size:

i. Image → Image Size

ii. In Pixel Dimensions set the drop down box to be Percent and for the Width, type 50 (you should see all the other height/width boxes change to 50 as well.)

iii. Again, leave all 3 check boxes at bottom checked and leave Resample Image as Bicubic.

iv. Click OK and the image should be reduced by 50%.

TIP: This 50% method works for many images coming out of TGA, but you may need to experiment with the correct reduction percentage for your images. An individual character should be about 1/16 to 1/8 of an inch wide.

c) Apply thresholding to get nice, thickly outlined characters – as thick as possible without having characters fuse together. (See the thresholding instructions in Step 2 part 2.)

d) Change mode to bitmap (black & white):

i. Image → Mode → Grayscale

ii. If asked, Discard Color Information.

iii. Image →  Mode → Bitmap

iv. Leave the output as 400 DPI and method as “Diffusion Dither”.

e) File → Save.  File Format: Windows → Depth: 1 bit

f) Repeat for all files in “Text”. Use Photoshop’s batch processing capability. (See the batch processing instructions in Step 2 part 2d ii.)

3. Open Infty Editor.

4. Import a .bmp file into Infty:

a) File → Import → Image File (OCR).

b) Click File Select and browse to the “Text” folder.

c) Make sure Files of Type is set to Image Files.

d) Highlight an image or group of images in the Text folder and click Open.

e) Select the radio button for 400 dpi resolution

f) Click on a file to highlight it and click Start Recognition.

5. Compare the results with the original text file, which should open in a separate window, and edit as necessary.

a) Use Math Mode formatting to insert subscripts (down arrow) and superscripts (up arrow). Use the right arrow to get out of the subscript or superscript.

b) Use Math Mode to insert greek letters and other mathematical symbols. This is done by typing a backslash, followed by the name of the symbol. For example a lower case gamma, γ, is inserted by typing “\gamma” (without the quotes). Alternatively, you may select the symbol from the dropdown box which appears when you type the backslash.

c) TIP: Sometimes Infty will read regular text as math. The text will show up in blue and italicized. Correct this by highlighting and changing to Text Mode. (It’s ok to leave it italicized, as this will be ignored by Duxbury.)
6. After editing, export as Latex file. 

a) File → Export → Latex

b) Keep the default settings and save to the same “Text” folder as the original image.

c) Make sure that when you save the file, you save as: figname.SelLabelsNoBoxes.tex (where “figname” is the actual figure name). 

TIP: Infty will leave out the “SelLabelsNoBoxes” by default, so you have to add it back in. If not, the scripts will not work.
Step 7: Braille Translation
1. Nemeth Code (for Greek characters, fractions, operations, etc) if needed.

a) Duxbury automatically will translate text into Nemeth code. However, during the OCR saving process, you may lose some of your math notation if you saved into a text file. For example, if you had a subscript when you saved, the resulting text file will remove the subscript.

b) For further information, an introduction to Nemeth code: http://www.dotlessbraille.org/NemethIntro.htm
c) To insert Nemeth code:

i. For those of you familiar with html, inserting Nemeth is like inserting html tags.

ii. Open up the translated text file you saved and find the line you need to edit with Nemeth code.

iii. Add in the Nemeth code using the reference sheets provided or the appendix at: http://people.rit.edu/easi/easisem/jones07.html
iv. Save and close the file. 

TIP: Always double check to make sure you used the right Nemeth code and that you closed your “tag”. For example, if you used an open fraction tag, make sure you have a close fraction tag.
d) Here is an example of the process: You have a label that is 2n. When OmniPage does an OCR, it may or may not recognize 2n. In either case, when you copy the text into Notepad, it will turn into 2n. After translating, you will get #b;n. Now we want to insert the superscript tag (the carrot symbol ^). This results in #b^;n. Save and close your translated text file.
Step 9: Editing in Illustrator and Photoshop
1. To aid you in making your own textures (if you want to make your own), here are two examples:

a) To create a dot pattern:

i. File → New

ii. Height and Width: 8 pixels. Click OK.

iii. Zoom in to see the square and with the brush tool, make a dot in the middle of the square.

iv. Use the Marquee tool to select the whole square.

v. Edit → Define Pattern

vi. Name it something meaningful like “Dots”.

b) To create a grid pattern:

i. File → New

ii. Height and Width: 20 pixels. Click OK.

iii. Layer → Duplicate Layer → OK

iv. Layer → Layer Style → Stroke

v. Size: 3px, Position: Inside, Click OK.

vi. Use the Marquee tool to select the whole square.

vii. Edit → Define Pattern

viii. Name it something meaningful like “Grid”.

c) Open the image you want to apply the pattern to.

d) Use the Marquee tool to select where you want to put the pattern.

TIP: If you want to select and replace a certain color, use the Magic Wand Tool.

e) Edit → Fill

f) Use: Pattern, Custom Pattern: Select “Dots” or “Grid”. Click OK.
Move the threshold slider left and right to filter the text
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Even though this image could fit on one page, split it up
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Example of what files are in the “Text” folder (yours will have a lot more files)
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Recognize image options for the second step





OCR A Extended font matching





Finishing step





We can see some errors in the OCR process. In this image, we have to extend the text box to include the “U”. The dots each need their own line and since we don’t have a character for them, they can be represented as blank lines.





After you fixed up the problems, export to text files





Save to file options





Sample output for runnumlines.bat





Translating with Duxbury





Copying the text back into Notepad





How to find the scripts





Example with the figure label and copyright information





Changing the dimensions of the art board
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Making a dot pattern





The stop button in the Action window
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